JUpgrade requiere Mootools Upgrade 1.2

Aprovechando la migración de Esfera5 : El Portal Espiritual de la Red me decidí a dedicar un poquito más de tiempo para hacer el upgrade del motor de Joomla sobre el que funciona el sitio a fin de resolver algunos issues de seguridad.

El primer paso fue realizar el upgrade de la versión 1.5.23 a la 1.5.26, lo cual fue prácticamente transparente.

Lo siguiente que me plantee fue migrar de la rama 1.5 a la 1.7 del Joomla, para lo cual existe una herramienta llamada JUpgrade que, según referencias, automatiza bastante bien la migración, sin embargo resultó que dicha herramienta no funcionó apropiadamente, al menos a la primera.

El asunto fue relativamente sencillo de resolver, una vez que pude descubrir la causa. Resulta que el JUpgrade requiere el Mootools Upgrade versión 1.2 para poder funcionar. Así que bastó con descargar el plugin e instalarlo desde el Instalador de Extensiones del Panel de Administración del Joomla.

Por cierto, no olviden ir al Gestor de plugins, en Systems -Mootools upgrade y publicar el plugin y seleccionar la versión a utilizar.

gestor_plugins